From: ptkwt@...1.aracnet.com (Phil Tomson) Date: 2003-05-17T18:23:54+09:00 Subject: Re: RCR: $INCLUDED global var In article <1053047645.721520.9976.nullmailer@picachu.netlab.jp>, Yukihiro Matsumoto wrote: >Hi, > >In message "Re: RCR: $INCLUDED global var" > on 03/05/16, ahoward writes: > >|__LIB__ ? >| >| __LIB__ -> __FILE__ != $0, eg. we have been included. > >"include" is the C term, we use "require". Anyway, I think the >condition should be reversed, since we check that way. > >In message "Re: RCR: $INCLUDED global var" > on 03/05/16, Joel VanderWerf writes: > >|What about >| >| MAIN { >| # ... >| } >| >|It's sorta analogous with BEGIN and END. > >Better. But I still want better name. > > matz. > IF_THIS_FILE { #OK, it's kind of klunky #... } -OR- TEST { #... } I like the second one, because that's what I'm usually using the code in that secion for; unit testing a module or class(s) that appear above in the file. Phil