From: dblack@... Date: 2003-05-17T14:02:15+09:00 Subject: Re: RCR: $INCLUDED global var Hi -- On Sat, 17 May 2003, Martin DeMello wrote: > dblack@superlink.net wrote in message news:... > > Hi -- > > > > On Fri, 16 May 2003, Yukihiro Matsumoto wrote: > > > > > In message "Re: RCR: $INCLUDED global var" > > > on 03/05/16, Joel VanderWerf writes: > > > > > > |What about > > > | > > > | MAIN { > > > | # ... > > > | } > > > | > > > |It's sorta analogous with BEGIN and END. > > > > > > Better. But I still want better name. > > > > RUN ? > > PROGRAM? (and LIBRARY for the other case, though I can't think of > anything you'd want in there only if the code was 'require'd). > Actually, I like MAIN - it has a lot of precedent. Precedent, baggage, whatever :-) My problem with MAIN is that it's not a good fit, in the sense that usually what gets put at the bottom is test code, typically in files that really aren't designed to be run by themselves. So the closest equivalent to "main" is probably in another file (i.e., one that 'require's this file). David -- David Alan Black home: dblack@superlink.net work: blackdav@shu.edu Web: http://pirate.shu.edu/~blackdav