From: Brian Candler Date: 2003-05-16T20:40:51+09:00 Subject: Re: RCR: $INCLUDED global var On Fri, May 16, 2003 at 07:54:36PM +0900, dblack@superlink.net wrote: > On Fri, 16 May 2003, Yukihiro Matsumoto wrote: > > > In message "Re: RCR: $INCLUDED global var" > > on 03/05/16, Joel VanderWerf writes: > > > > |What about > > | > > | MAIN { > > | # ... > > | } > > | > > |It's sorta analogous with BEGIN and END. > > > > Better. But I still want better name. > > RUN ? If it's a method then it can't have an initial capital, can it? if INVOKED_DIRECTLY ... end when_invoked_directly { # ... } perhaps?? Regards, Brian.