From: matz@... (Yukihiro Matsumoto) Date: 2003-05-06T17:54:47+09:00 Subject: Re: Suggestion: String#pack Hi, In message "Suggestion: String#pack" on 03/05/06, Austin Ziegler writes: |I have been working on some code recently where it would be very |useful to do: | | "abcdef".pack(...) | |Instead, I have to do: | | ["abcdef"].pack(...) Pack templates A, a, Z, B, b, H, h, u, m, P and p takes string argument, so that it might be useful. But they are subset of pack function. Do we have to name different name for different function? String#pack might not be intuitive name for string padding/converting function. matz.