From: Gavin Sinclair Date: 2003-04-28T19:33:41+09:00 Subject: Re: block.call vs. yield On Monday, April 28, 2003, 8:13:01 PM, dblack wrote: > Hi -- > On Mon, 28 Apr 2003, Gavin Sinclair wrote: >> If you want to take a step back and look for a unifying concept, which >> I applaud, then I think the only choice is to abolish "yield >> semantics". The splat (*) operator allows you to achieve the same >> result anyway - when you want to. > I'm not seeing why that's the only choice. How about finding a > better name? :-) I can't think of anything other than: blk.call_but_collapse_surplus_arguments_into_the_final_parameter_as_an_array :) This concept does not, AFAIK, map to any short name. Nor is it endorsed by any theory in computer science. I'd be interested to know the origin and purpose of "yield semantics", but I doubt they derive from some "best practice". My conclusion: yield semantics are unlikely to ever be known as anything other than yield semantics :) It has nothing to do with yielding; it's just, as you said, historical. Gavin