From: Florian Frank Date: 2003-02-12T03:50:10+09:00 Subject: Re: Range#length? On 2003-02-12 03:12:19 +0900, Yukihiro Matsumoto wrote: > Do you think of a good name for it? I'm glad to add a method if > you have a good name. It doesn't seem to work for general ranges: r = "a".."z" ==>"a".."z" r.last - (r. exclude_end? ? 1 : 0) NoMethodError: undefined method `-' for "z":String from (irb):4 -- The whole problem with the world is that fools and fanatics are always so certain of themselves, but wiser people so full of doubts. -- Bertand Russell