From: matz@... (Yukihiro Matsumoto) Date: 2003-02-12T03:12:19+09:00 Subject: Re: Range#length? Hi, In message "Re: Range#length?" on 03/02/12, "Chris Pine" writes: |Well, it's a shame that something wasn't put in to refer to the last actual |element in the range. That's actually all I want. As I said, #end, #last, |and #max all return `99' for both 3..99 and 3...99. | |Oh, well. Nothing a good ``last - (exclude_end? ? 1 : 0)'' can't handle. Do you think of a good name for it? I'm glad to add a method if you have a good name. matz.