From: Gavin Sinclair Date: 2003-01-06T13:30:06+09:00 Subject: Re: attr_cast, one a small step for interface techniques On Monday, January 6, 2003, 1:20:06 PM, Jim wrote: > Wow, that's cool. But, should it be named somthing like: > attr_accessor_cast > or > attr_accessor_with_cast Those both being annoyingly long, I would prefer an implementation that allowed: attr_accessor :x, :y, :name => :to_s, :age => :to_i That is, :x and :y receive the normal attr_accessor treatment, while :name and :age get casting as well. You wouldn't be able to put "non-cast" arguments after "cast" arguments, because, well, that's the way Ruby inline hash arguments work, but that draws no complaint from me. Gavin