From: Tom Sawyer Date: 2003-01-06T13:08:56+09:00 Subject: Re: attr_cast, one a small step for interface techniques On Sunday 05 January 2003 07:20 pm, Jim Freeze wrote: > Wow, that's cool. But, should it be named somthing like: > > attr_accessor_cast > or > attr_accessor_with_cast thanks, Jim. it is esspecially usefull for cgi apps, since all the cgi parameters come in as strings. you are probably right about the name although it seems so long winded to say 'attr_accessor_with_cast' but its not so bad since you can do things like: att_accessor_with_cast :a1 => :to_s, :a2 => :to_i, :a3 => :to_f which of your two suggestions go you think best? and i will change it to that. -transami