From: Paul Brannan Date: 2002-12-28T01:07:55+09:00 Subject: Re: change in lookup of constants on 1.6.8? On Fri, Dec 27, 2002 at 12:44:32PM +0900, Yukihiro Matsumoto wrote: > In message "change in lookup of constants on 1.6.8?" > on 02/12/27, Paul Brannan writes: > > |What has changed in Ruby to cause this behavior? Is there a change I > |can make to foo() or to Foo to allow the block passed to foo() to work? > > I wanted to make constant scope more static. It's for readability and > for future optimization. There's no way to switch constant scope. I can see how this would help in optimization. How does it add readability? How big a performance boost do you expect this change (plus future optimizations) to give? Paul