From: matz@... (Yukihiro Matsumoto) Date: 2000-10-03T00:43:17+09:00 Subject: [ruby-talk:5237] Re: better way to say 'recursive join' In message "[ruby-talk:5231] Re: better way to say 'recursive join'" on 00/10/02, Dave Thomas writes: |> |> $ ruby -e "Thread.current.join" |> -e:1:in `join': recursive join (ThreadError) |> from -e:1 | |If it occurs when a thread tries to join itself, how about: | | -e:1:in `join': thread tried to join itself (ThreadError) Thank you. Done. matz.