From: dblack@... Date: 2002-09-25T23:23:45+09:00 Subject: Re: select and select Hi -- On Wed, 25 Sep 2002, Harry Ohlsen wrote: > > In another thread, which he accidentally created, Hugh suggested #lookup > > which I think is very worthy. > > Since we're nit-picking ... don't get me wrong, there's absolutely nothing > wrong with that !! ... I think it should be #look_up, since "lookup" is not a > word (well, not in English, anyway), and never will be, no matter how many > times programmers try to make it one. > > I suggest this in the same way I think other people would suggest #values_at > rather than #valuesat. My pedant credentials are pretty good (I get paid to do it :-) but I don't think "lookup" is in the same category of illegitimacy as "valuesat". "lookup" has a huge amount of currency; it's not a coinage. In fact, it's even in dictionary.com's dictionary, though I'm not one to point to inclusion in a dictionary as a slam-dunk (or slamdunk :-) argument. Or is the problem that lookup is (or should be) only the noun form, while the method name should be verb-ish? > My pet peeve in this regard is "login" versus "log in" :-(. I'll take either of those over "logon"... :-) I guess if you don't have the noun "login", you have to say, "There were a lot of logs in on the system yesterday." :-) David -- David Alan Black | Register for RubyConf 2002! home: dblack@candle.superlink.net | November 1-3 work: blackdav@shu.edu | Seattle, WA, USA Web: http://pirate.shu.edu/~blackdav | http://www.rubyconf.com