From: Gavin Sinclair Date: 2002-09-25T14:43:57+09:00 Subject: Re: select and select ----- Original Message ----- From: "Harry Ohlsen" > > In another thread, which he accidentally created, Hugh suggested #lookup > > which I think is very worthy. > > Since we're nit-picking ... don't get me wrong, there's absolutely nothing > wrong with that !! ... I think it should be #look_up, since "lookup" is not a > word (well, not in English, anyway), and never will be, no matter how many > times programmers try to make it one. > > I suggest this in the same way I think other people would suggest #values_at > rather than #valuesat. > > My pet peeve in this regard is "login" versus "log in" :-(. > > Yours, pedantically, > > Harry O. I myself am a pedant, and always appreciate advice from other pedants. I would not have considered #lookup to be a problem, in fact I didn't give it any thought, because "lookup" to me suggests a search, whereas "look up" suggest gazing at the sky or the ceiling, depending on one's location. Anyway, I went to dictionary.com, and guess what? Their search box is labelled "Look up:"!!! So I rest your case. I still prefer #lookup, because I dislike underscores in built-in method names. (Rationale: aesthetic, but to me, something "in the language" should be distilled into a single word. Keywords, for example.) Sorry for boring the 97% of people who couldn't care less about all this! Gavin