From: Paul Brannan Date: 2002-08-21T04:52:00+09:00 Subject: Re: Data_Make_Struct and ALLOC Considered Harmful? On Wed, Aug 21, 2002 at 04:30:47AM +0900, William Djaja Tjokroaminata wrote: > Mauricio Fern?ndez wrote: > > I can't see the point of this, but wouldn't SAFE_ALLOC (a wrapper to > > ALLOC which memsets to 0) be a better solution? > I also like your suggestion of SAFE_ALLOC(), although for philosophical > reason, I choose SAFE_MALLOC(). Or perhaps CALLOC or RUBY_CALLOC, to be consistent with C naming convention. Paul