From: stefano Date: 2002-08-08T17:05:59+09:00 Subject: Re: Named paramters again On Wed, 07 Aug 2002 19:11:25 +0200, Kent Dahl wrote: > class Array > def insert( element:, at: ) > # in here, 'at' is just plain ugly > insertion_index = at > end > end > anArray = Array.new > anArray.insert("new element", at: 5 ) # but here 'at' is more readable What about: class Array def insertElement:element at:position ... end end anArray = Array.new anArray.insertElement:"new element" at:5 Just like Objective-C (or Smalltalk) -- ste