From: Zakaria Date: 2002-07-21T12:00:17+09:00 Subject: Converting from Runit to TestUnit Hi, Yesterday I just convert my application to the new Test::Unit. After reading some ruby-talk archive some of them already in Nat's TODO list but I include them as a reminder. Here is my impression: 1. There should be a warning about the rename of setup to set_up. Is there any way to issue a warning from a library? like Perl warn. 2. What flunk means? Maybe it should renamed to assert_fail (like Runit) or any other better name. I also need assert_ok(message = "") so my test is in symmetry. 3. I prefer the RUnit Console Test Runner, it is more verbose and the dot distract me from the Failure/Error message. If you still prefer the dot then make the verbose mode an option so I could run my test like this ./my_test.rb -v 4. Remove the ellipsis (...) in "Started..." 5. Rather than ===================================================================== Failure occurred in test_method(TestClass) [./t.rb:20]: Some_long_msg ===================================================================== I prefer ===================================================================== Failure in TestClass#test_method [./t.rb:20]: Some_long_msg ===================================================================== Anyway, thank you Nat for a wonderful unit test framework. Wassallam, -- Zakaria Private: z4k4ri4@bigfoot.com Yahoo!: z4k4ri4 http://pemula.linux.or.id