From: Justin Johnson Date: 2002-07-18T19:09:34+09:00 Subject: Re: Syntax "surprise" > Ruby with Objective-C's message syntax? Now that's something I could > really get behind... we could change the block syntax from {} to [] > while we're at it, get rid of control structures in favor of methods > like ifTrue:ifFalse:, build a class browser or two, and we'd have a > great little language ;-) A few postings elsewhere have given examples of getting something that's similar to Objective-C's (and SmallTalks) message syntax. Like a few other people here, I think that naming message parameters can improve readability. I wonder if it would at all be worth considering a little syntactic sugar for this? obj.my_method( :x => 10, :y => 20, :z => 30 ) sweetened to: obj.my_method( x: 10, y: 20, z: 30 ) where the ':' at the end of a parameter var really treats the var name as a symbol and behaves as though it's followed by a '=>'. Look neat to me. What does anybody else think? I think the blocks use {} because they are more familiar to many programmers. After first looking at SmallTalk, I found the [] for blocks strange until I got used to it. [] are used often for indexing in lots of other languages. Hey, wait a minute....are you trying to turn Ruby into SmallTalk? :o) -- Justin Johnson