From: Tobias Reif Date: 2002-07-06T04:21:50+09:00 Subject: Re: (0..3) == (0...4) returning false? Clifford Heath wrote: > Tobias Reif wrote: > >>What about a class Continuum and a class Sequence? >> > Though you suggested that naming isn't important, I'd like to suggest > that Sequence would be too general a name. To indicate how different an > meaning of "Sequence" could be, I've used it to name a container class > (like Hash) implemented using AVL trees to maintain the keys in sorted > order. Your sequence name would need to connote consecutive integers. ... or simply Array.new (4..15) Tobi -- http://www.pinkjuice.com/