From: ahoward Date: 2002-05-24T14:47:49+09:00 Subject: Re: cannot require 'postgres' from cgi On Thu, 23 May 2002, Sean Chittenden wrote: > Why aren't you using DBI? just one more thing to learn - haven't had time. plus i'd read some things about speed issues and hadn't had time to investigate. what are you opinions of it? turns out (this took me a LONG time to determine) that the postgres.so lib has dependancies on other libs which are not to be found in the LD_LIBRARY_PATH (empty) of the default cgi environment but that WERE found in my own LD_LIBRARY_PATH. it's a little troublesome that 'require' is unable to throw for this sort of error... anyhow, i'm unsure of where to go from here - install postgress libs in /usr/lib - modify ENV of running cgi - staticaly link the postgres lib ??? any opinions on this? -a -- ==================================== | Ara Howard | NOAA Forecast Systems Laboratory | Information and Technology Services | Data Systems Group | R/FST 325 Broadway | Boulder, CO 80305-3328 | Email: ahoward@fsl.noaa.gov | Phone: 303-497-7238 | Fax: 303-497-7259 ====================================