From: Austin Ziegler Date: 2013-04-21T10:41:44+09:00 Subject: [ANN] mime-types 1.23 Released mime-types version 1.23 has been released! * home: * code: * bugs: * rdoc: This library allows for the identification of a file's likely MIME content type. This is release 1.23 that adds the ability to enumerate over the collection of MIME types and updates the sources of a few MIME types. The identification of MIME content type is based on a file's filename extensions. MIME types are used in MIME-compliant communications, as in e-mail or HTTP traffic, to indicate the type of content which is transmitted. MIME::Types provides the ability for detailed information about MIME entities (provided as a set of MIME::Type objects) to be determined and used programmatically. There are many types defined by RFCs and vendors, so the list is long but not complete; don't hesitate to ask to add additional information. This library follows the IANA collection of MIME types (see below for reference). MIME::Types for Ruby was originally based on and synchronized with MIME::Types for Perl by Mark Overmeer, copyright 2001 - 2009. As of version 1.15, the data format for the MIME::Type list has changed and the synchronization will no longer happen. MIME::Types is built to conform to the MIME types of RFCs 2045 and 2231. It follows the official {IANA registry}[http://www.iana.org/assignments/media-types/] ({ftp}[ftp://ftp.iana.org/assignments/media-types]) with some unofficial types added from the the {LTSW collection}[http://www.ltsw.se/knbase/internet/mime.htp]. Changes: ## 1.23 / 2013-04-20 * New Feature: * Arnaud Meuret (ameuret) suggested that it could be useful if the MIME type collection was enumerable, so he implemented it in #30. Thanks for the contribution! https://github.com/halostatue/mime-types/pull/30 * Updated MIME Types: * RFC6910 was adopted (application/call-completion). * RFC6902 was adopted (application/json-patch\+json). * RFC6917 was adopted (application/mrb-consumer\+xml, application/mrb-publish\+xml). * RFC6922 was adopted (application/sql). * RFC2560 is being {updated}[http://tools.ietf.org/html/draft-ietf-pkix-rfc2560bis]. * Administrivia: * The gemspec now includes information about the licenses under which the mime-types gem is available. * Using hoe-gemspec2 instead of hoe-gemspec.