From: Robert Klemme Date: 2013-04-02T19:58:23+09:00 Subject: Re: Grasping methods like "to_s"? --20cf3074d6a04f819c04d95e9d05 Content-Type: text/plain; charset=ISO-8859-1 On Sat, Mar 30, 2013 at 11:30 PM, Peter Hickman < peterhickman386@googlemail.com> wrote: > Or perhaps just > > class Object > def is_i? > self.is_a? Integer > end > end > > Herewith I call the "useless use of self award" (UUOSA) to life. We have a first nominee. :-) SCNR Cheers robert PS: That would have been a good posting for yesterday... -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/ --20cf3074d6a04f819c04d95e9d05 Content-Type: text/html; charset=ISO-8859-1 Content-Transfer-Encoding: quoted-printable



On Sat, Mar 30, 2013 at 11:30 PM, Peter Hickman &= lt;pete= rhickman386@googlemail.com> wrote:
Or perhaps just

class Object
=A0 def is_i?
=A0 =A0 self.is_a? I= nteger
=A0 end
end


Herewith I call the "useless use of self award&= quot; (UUOSA) to life. =A0We have a first nominee. :-)

SCNR

Cheers

robert


PS: That would have been a good posting for yesterday...

--
remember.guy do |as, often| as.you_can = - without end
http://blog= .rubybestpractices.com/
--20cf3074d6a04f819c04d95e9d05--