From: stomar Date: 2013-02-08T06:30:36+09:00 Subject: Re: Issues from an extreme beginner Am 07.02.2013 07:43, schrieb Bruce Palmer: > Ahh, thank you Matthew! That was just the push I needed! > > I don't know what I was thinking before, brain fart perhaps, but I was > unnecessarily converting back and forth between string and integer. > > Anyway, this is the winning program: > > puts 'Enter your first, middle and last name:' > name1 = gets.chomp > name2 = gets.chomp > name3 = gets.chomp > names = name1.length + name2.length + name3.length > puts 'There are ' + names.to_s + ' character\'s in your name!' You should make it a habit from the start to use more accurate variable names, like characters = name1.length + name2.length + name3.length # or: character_number, total_characters, total_character_number, ... puts "There are #{characters} characters in your name!" stomar