From: masta Blasta Date: 2013-01-26T00:49:29+09:00 Subject: Re: Enum#select with max number of items Robert Klemme wrote in post #1093631: > or > > new_arr = [] > > my_arr.each do |ele| > condition and > new_arr << ele and > new_arr.size >= limit and > break > end > This is clever but is there a specific technical reason for using 'and'. To me it makes it harder to read than conventional structure. -- Posted via http://www.ruby-forum.com/.