From: Intransition Date: 2012-11-25T21:33:03+09:00 Subject: [ANN] Hashery 2.1.0 (Golden Retriever) ------=_Part_897_18806527.1353846781477 Content-Type: multipart/alternative; boundary="----=_Part_898_30877872.1353846781480" ------=_Part_898_30877872.1353846781480 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Hashery 2.1.0 (Golden Retriever) has been released. The major change of this release is to switch to `Hash#fetch` as the fundamental CRUD read method in place of the `#read` core extension (an alias of `#[]`). This is a pretty fundamental change which required modification of a number of classes. So, please, don't hesitate to file an issue if you experience any problems. In addition, the Hash#read core extension has been renamed to Hash#retrieve to avoid any possible confusion with IO objects. This release also fixes a couple of issues with 1.8 compatibility and makes a few other small enhancements. Changes: * Rename Hash#read to Hash#retrieve. * Deprecate `Dictionary.alpha` in favor of `Dictionary.alphabetic`. * Add support for block argument in Dictionary#order_by_key and #order_by_value. * Fix OpenHash issues with Ruby 1.8.x compatibility. * OpenHash methods are opened up via `protected` instead of `private`. * Change OpenCascade to auto-create the subclass when inherited. ------=_Part_898_30877872.1353846781480 Content-Type: text/html; charset=utf-8 Content-Transfer-Encoding: quoted-printable
Hashery 2.1.0 (Golden Retriever) has been released.

The major change of this release is to switch to `Hash#fetch` a= s the fundamental CRUD read method in place of the `#read` core extens= ion (an alias of `#[]`). This is a pretty fundamental change which req= uired modification of a number of classes. So, please, don't hesitate to&nb= sp;file an issue if you experience any problems.

I= n addition, the Hash#read core extension has been renamed to Hash#retrieve&= nbsp;to avoid any possible confusion with IO objects. This release also fix= es a couple of issues with 1.8 compatibility and makes a few other sma= ll enhancements.

Changes:

* Rename Hash#read to Hash#retrieve.
* Deprecate `Dictionary.alp= ha` in favor of `Dictionary.alphabetic`.
* Add support for block = argument in Dictionary#order_by_key and #order_by_value.
* Fix Op= enHash issues with Ruby 1.8.x compatibility.
* OpenHash methods a= re opened up via `protected` instead of `private`.
* Change OpenC= ascade to auto-create the subclass when inherited.

------=_Part_898_30877872.1353846781480-- ------=_Part_897_18806527.1353846781477--