From: "Jan E." Date: 2012-09-18T17:18:47+09:00 Subject: Re: how to sum element of array Or a bit more serious: ;-) The smaller the scope, the less descriptive do variable names need to be. I mean, in this case you can *see* where the variable comes from, so why give it a long name like "integer_element"? Nontheless, "i" actually isn't a good choice, because it's mostly used for indices. But "e" should be fine. -- Posted via http://www.ruby-forum.com/.