From: Lars Haugseth Date: 2012-07-20T18:10:52+09:00 Subject: Re: unless if not == unless post_on_ruby_forum On 07/20/2012 06:17 AM, Matthew Kerwin wrote: > [unless is] most useful for perl-esque one-liners: > > die unless it_worked Personally I find the following much more readable: do_something or raise SomethingFailedException -- Lars Haugseth