From: Robert Klemme Date: 2012-07-11T15:45:05+09:00 Subject: Re: Lambdaification of Method Calls On Wed, Jul 11, 2012 at 3:40 AM, Matthew Kerwin wrote: > My only request would be that you rename the method something like > 'create_lambda' (since you're not really casting s as such, you're > using it as a factory) or get_lambda (if you want to make the lambda > seem like a property of s). It's not a "get" since we actually create something. I prefer #to_lambda (or #to_something_else) because it actually converts the object to something else (btw. #to_enum works similarly, i.e. by wrapping the instance at hand with something else which provides a particular interface). Also "to" is shorter to type than "create". :-) > Aside from that, I can see it being a rather fun way to blow my feet > off and confuse my colleagues, which are always my primary goals at > work. (Spice of life, and all that.) Yeah, that's the spirit! :-) Cheers robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/