From: Marc Heiler Date: 2012-06-28T05:03:05+09:00 Subject: Re: Is this good code > The conditional dependent 'end' is irritating me a lot. I don't mind > mid method break or return statements, but this just looks obnoxious. > I'm tempted to re-write the whole method to get rid of it. If it bothers your brain to look at it, definitely rewrite it so that your brain feels more comfortable. I myself use short conditionals usually only in block form. Example: def foo invoke_this_method { method_one method_two } unless @run_application end This is not that easy to read for others, and I don't do it often, but when I do it, I try to make it be the last part of the method. Having an: "end unless condition_is_true" in the middle of a method can be difficult to follow. I try to keep things as simple as possible usually though, so I rarely use a construct like this. -- Posted via http://www.ruby-forum.com/.