From: Michel Demazure Date: 2012-04-26T20:59:18+09:00 Subject: Re: A question of style Robert Klemme wrote in post #1058460: > On Thu, Apr 26, 2012 at 1:47 PM, Michel Demazure > wrote: >> J2R.logger.info("report created") >> bottom_message "Nombre de lignes #{@report.size}" >> else >> J2R.logger.error("error creating report") >> bottom_message "Erreur la cration du rapport" >> end >> end > > Looks perfectly OK to me. Creating two additional methods seems like > a lot of overkill which hinders readability. My 0.02 EUR... > > Kind regards > > robert Glad you agree ! reek can be overstuffed. (I guess you are somewhere farther on the Loire. Sun in Tours for the time being...). _md -- Posted via http://www.ruby-forum.com/.