From: Robert Klemme Date: 2012-04-26T20:56:10+09:00 Subject: Re: A question of style On Thu, Apr 26, 2012 at 1:47 PM, Michel Demazure wrote: > Robert Klemme wrote in post #1058456: >> >> What does the real code look like? >> > One example : > >      def create_report >        report = @recipe.run_with_logger(@parameter_values) >        if report >          @report = report >          J2R.logger.info("report created") >          bottom_message "Nombre de lignes #{@report.size}" >        else >          J2R.logger.error("error creating report") >          bottom_message "Erreur à la création du rapport" >        end >      end Looks perfectly OK to me. Creating two additional methods seems like a lot of overkill which hinders readability. My 0.02 EUR... Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/