From: Robert Klemme Date: 2012-02-09T17:34:54+09:00 Subject: Re: Using _ like in Scala? On Wed, Feb 8, 2012 at 9:55 PM, Kevin wrote: > Wouldn't the general use case at issue here be addressed by adding > standalone versions of various functions traditionally associated with > collections so that one could call say reduce like "reduce myarray, > :+"? I do not think it is a good idea as a general rule because that totally breaks OO. And cluttering the global namespace with a ton of methods which just delegate to instance methods with the same name does not seem a good idea to me either. As a general remark: we need to balance readability (which generally benefits from making things explicit, but not too many things) and writing efficiency (less text => more implicit). Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/