From: Robert Klemme Date: 2011-10-18T15:13:40+09:00 Subject: Re: Help figuring out appropriate naming scheme (previously 'wedge') On Tue, Oct 18, 2011 at 6:51 AM, Intransition wrote: > > > On Oct 17, 9:57 pm, "Sean O'Halpin" wrote: >> On Fri, Oct 14, 2011 at 5:01 PM, Intransition wrote: >> > As you can see I've gone round and round with ideas and nothing has >> > really struck me as the "Ah ha!" right way to go. So I've turned to >> > the ruby community for any suggestions. Appreciate any guidance others >> > can give. >> >> I'd go for LoadHook myself. And steer clear of RbConfig. > > Ah, LoadHook. That is a good name. Might well have used it too, except > Loadable turned up and it looks like it will work to good result. Why not use the gem's name as namespace, e.g. module Wedge end or module LoadWedges end I also find the name "RubyLoader" too unspecific. I mean, it's clear that it's Ruby because that is the language it was written for and in. But I get no idea what it really does. Can you describe what it really does? If all else fails BaseLoader or just Base might be a good choice (after all, you have it namespaced already). Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/