From: Marc Heiler Date: 2011-08-22T23:11:23+09:00 Subject: Re: Possble bug in Ruby parser (Fixnum#times within "case" statement) When I use case/when, I tend to use: loop { } rather than while. I found it is much more readable that way. loop { user_input = $stdin.gets.chomp case user_input when 'foo' when 'bar' when 'q','exit','quit' exit end } Seems to read much better than: while foo > bla -- Posted via http://www.ruby-forum.com/.