From: Robert Klemme Date: 2011-07-25T16:11:57+09:00 Subject: Re: Better name for #zip_with On Mon, Jul 25, 2011 at 1:16 AM, Intransition wrote: > I'm starting to think, however, that it makes more sense to add > optional arguments to #map itself. Consider that #zip returns an assoc > array, that's it's expected behavior. So it's probably best not to > alter that. Whereas map can return any form of array based on the > block. > >    [1,2,3].map([2,3,4], [5,6,7]) { |a,b,c| ... } Wouldn't that be [1,2,3].map([2,3,4], [5,6,7]) { |a,b| ... } ? > Map has free arguments, so why not? Orthogonality probably. And it is not entirely clear whether map + zip is the most common or most useful use. Others may want to use arguments to #map for #grep like selection or even other uses. Who decides which use wins and becomes standard? Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/