From: Intransition Date: 2011-07-18T12:30:03+09:00 Subject: Re: Better name for #zip_with On Jul 17, 10:36 pm, John Feminella wrote: > How about #zip_and_map? Notice that: > > > a.zip_with(b) { |c, d| ... } > > is the same as the result of > > > a.zip(b).map { |c, d| ... } Ah, right. `#zip_map` would makes sense then. But per your last post, I think I may override #zip itself.