From: Intransition Date: 2011-07-18T12:28:37+09:00 Subject: Re: Better name for #zip_with On Jul 17, 10:13 pm, John Feminella wrote: > Doesn't zip basically do that already? > > ruby-1.9.2-p180 :001 > l = [1,2,3]; r = [6,5,4] >  => [6, 5, 4] > ruby-1.9.2-p180 :002 > arr = []; l.zip(r) { |first, second| arr << 3 * > first + second }; arr >  => [9, 11, 13] > > (Are you just trying to save the last step?) Actually, I didn't know zip took a block. Good to know. So yea, that makes it much closer than I realized. But why doesn't it map the results? That's unfortunate. I think I will submit a feature request for Ruby. Thanks.