From: John Feminella Date: 2011-07-18T11:36:09+09:00 Subject: Re: Better name for #zip_with How about #zip_and_map? Notice that: > a.zip_with(b) { |c, d| ... } is the same as the result of > a.zip(b).map { |c, d| ... } ~ jf -- John Feminella Principal Consultant, BitsBuilder LI: http://www.linkedin.com/in/johnxf SO: http://stackoverflow.com/users/75170/ On Sun, Jul 17, 2011 at 21:44, Intransition wrote: > Any ideas for a better name for: > >    [1,2,3].zip_with([6,5,4]) { |a, b| 3 * a + b } #=> [9, 11, 13] > > #zip_with comes from Haskell, but I think it's confusing because of > Ruby's #zip. > > >