From: John Feminella Date: 2011-07-18T11:13:44+09:00 Subject: Re: Better name for #zip_with Doesn't zip basically do that already? ruby-1.9.2-p180 :001 > l = [1,2,3]; r = [6,5,4] => [6, 5, 4] ruby-1.9.2-p180 :002 > arr = []; l.zip(r) { |first, second| arr << 3 * first + second }; arr => [9, 11, 13] (Are you just trying to save the last step?) ~ jf -- John Feminella Principal Consultant, BitsBuilder LI: http://www.linkedin.com/in/johnxf SO: http://stackoverflow.com/users/75170/