From: Intransition Date: 2011-07-18T10:44:14+09:00 Subject: Better name for #zip_with Any ideas for a better name for: [1,2,3].zip_with([6,5,4]) { |a, b| 3 * a + b } #=> [9, 11, 13] #zip_with comes from Haskell, but I think it's confusing because of Ruby's #zip.