From: "James F.Hranicky" Date: 2002-04-17T22:45:29+09:00 Subject: Re: Help wanted for statvfs extension On Wed, 17 Apr 2002 22:35:09 +0900 "nobu.nokada@softhome.net" wrote: > Hi, > > At Wed, 17 Apr 2002 22:09:50 +0900, > James F.Hranicky wrote: > > > Almost agree, but isn't "Fs" too short? Is it obvious enough? > > > > I guess that's a matter of personal taste. I like it, but perhaps > > FileSystem or FileSys would be better? > > Perhaps. At least, looks more obvious to me. Anyway, how > about an inner class of File? Although it may be redundant. My preference would be to keep filesystem stuff separate from the File class, allowing them to communicate with directory names, e.g., FileSys.all_mounted { |fs| Find.find(fs.mount_point) { |dir| .... } } Jim