From: Robert Klemme Date: 2011-06-24T16:46:37+09:00 Subject: Re: How to order a hash based on its keys? On Thu, Jun 23, 2011 at 7:12 PM, Iņaki Baz Castillo wrote: > 2011/6/23 Robert Klemme : >> I rather use specific types than Array and Hash since those make the >> code more readable.  Also, this encourages more OOish programs where >> you distribute functionality across classes. > > I know that my code is not very "ellegant" and does not follow Ruby's fashion :) > But this code will not be exposed to users of a library. Instead this > will be used internally by my application/library, which will expose > decent API methods. Still the readability argument applies. Imagine you have to maintain the code after a year not looking at it - or someone else has to maintain it... :-) Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/