From: Chad Perrin Date: 2011-06-17T06:58:26+09:00 Subject: Re: RFC - One word alias for require_relative --J2SCkAp4GZ/dPZZf Content-Type: text/plain; charset=us-ascii Content-Disposition: inline Content-Transfer-Encoding: quoted-printable On Fri, Jun 17, 2011 at 04:35:21AM +0900, Mike Moore wrote: >=20 > The stated question that began this thread is what alternative to > "require_relative" would you choose, asking only that the new single > word was 7 characters or less. I have a word in mind, but let me first > hypothesize on why "require_relative" was chosen in the first place. On > the surface having a multi-word name for this functionality seems to go > counter intuitive to Ruby's ease and flow that we all love. Why would > something so basic have a name that was so uncomfortable? As I said > earlier, I have a hard time even keeping the name right in my head! Why > would the Ruby culture create and propagate something so out of place > and ill-tasting? I think the actual reason for it was to follow a naming convention akin to namespace management. The namespace is "require", and "relative" is the extension of functionality within that namespace, so we end up with "require_relative". This is similar, in effect, to the way a Require library might be extended by a Relative library, yielding a name like "Require::Relative". In this case, however, it is a method name, and not a library name, so it is called "require_relative" rather than being called "Require::Relative". >=20 > My friends, I have the answer: >=20 > alias ilias require_relative >=20 > I sincerely hope my suggestion, a single word with 7 characters or > less, can help bring some closure to this topic. Unfortunately, anyone who was not privy to the thread trolled into existence by Ilias would not get the reference, and it would serve no mnemonic value. If, however, you think this "problem" does not actually need to be solved for anyone not already aware of this thread, I guess your proposal is perfect. --=20 Chad Perrin [ original content licensed OWL: http://owl.apotheon.org ] --J2SCkAp4GZ/dPZZf Content-Type: application/pgp-signature Content-Disposition: inline -----BEGIN PGP SIGNATURE----- Version: GnuPG v2.0.14 (FreeBSD) iEYEARECAAYFAk36ePAACgkQ9mn/Pj01uKWA0gCgnAfxo6V32Q7dChSmIUj+vRKD sg0An2LgpG/Dz+ixQi37BDrd9IqOrmh2 =kCt+ -----END PGP SIGNATURE----- --J2SCkAp4GZ/dPZZf--