From: David Masover Date: 2011-06-16T06:36:59+09:00 Subject: Re: RFC - One word alias for require_relative On Wednesday, June 15, 2011 04:15:29 PM Ilias Lazaridis wrote: > On 15 Ιούν, 22:58, Michael Edgar wrote: > > On Jun 15, 2011, at 3:55 PM, Ilias Lazaridis wrote: > > > And so I still need a shorter name. > > > > If *you* need a shorter name for some absurd reason, > > If something is absurd, than it's the fact that the name > > "require_relative" > > has made it into the core. For sure this was kind of an accident, > because everyone was busy or tired or something else. Of course, because the only reason anyone would ever disagree with you is because they're busy, tired, stupid, or the wrong "kind" of person. > Either it should be corrected soon to be a key*word*. It's not a keyword, it's a method. It's also far from the only two-word method -- consider define_method or instance_variable_set. > or at least, if multi-word, then it should be written more clearly: > > "require_relative_to_this_file" At a certain point, you have to assume that if it isn't obvious from the context what something does, people are willing to look it up. 'locally' isn't any better in this regard -- in fact, it's significantly worse, since at least we know what 'require' usually means. The alternative is Java-like madness, where define_method is actually define_method_on_this_class_with_this_block_I_pass_in_here. > There are many ways to ruin a language. Dramatic much? require_relative couldn't ruin a language -- it barely even touches the language, and can trivially be renamed or removed at runtime: Kernel.send :remove_method, :require_relative Oh, sorry, I guess that should be: Kernel.send_method_call :remove_method_from_this_class :require_relative