From: Ilias Lazaridis Date: 2011-06-16T06:15:29+09:00 Subject: Re: RFC - One word alias for require_relative On 15 Ιούν, 22:58, Michael Edgar wrote: > On Jun 15, 2011, at 3:55 PM, Ilias Lazaridis wrote: > > > And so I still need a shorter name. > > If *you* need a shorter name for some absurd reason, If something is absurd, than it's the fact that the name "require_relative" has made it into the core. For sure this was kind of an accident, because everyone was busy or tired or something else. Either it should be corrected soon to be a key*word*. or at least, if multi-word, then it should be written more clearly: "require_relative_to_this_file" There are many ways to ruin a language. Step by step, silently. > then *you* can simply do the following: > > module Kernel >   alias locally require_relative > end I am aware of this mechanism. > Where "locally" can be any name *you* wish! But still, I need a concise name. > Problem solved! . -- http://lazaridis.com