From: redstun Date: 2010-12-15T16:40:16+09:00 Subject: Re: String.populate(data) for sprintf? Ah, right, so I was just asking for something like class String alias :populate :% end hmmm, now I'm not sure if this worth the merit of readability On Dec 15, 2:38 pm, Yukihiro Matsumoto wrote: > |fmt_str = 'aligned numbers: %6d %6d" > |result = fmt_str.populate(1, 2) > > fmt_str = "aligned numbers: %6d %6d" > result = fmt_str % [1, 2] > >                                                         matz.