From: "Ilya B." Date: 2010-12-09T02:55:59+09:00 Subject: Ruby Koans: about_hashes.rb Question about this method in Ruby Koans -> about_hashes.rb def test_changing_hashes hash = { :one => "uno", :two => "dos" } hash[:one] = "eins" expected = { :one => "eins", :two => "dos" } assert_equal true, expected == hash # Bonus Question: Why was "expected" broken out into a variable # rather than used as a literal? end Referring to the bonus question, is there any reason other than that it's more readable this way? Seems to accomplish the same thing? -- Posted via http://www.ruby-forum.com/.