From: Robert Dober Date: 2010-12-03T02:24:50+09:00 Subject: Re: newbie: variable names On Thu, Dec 2, 2010 at 6:07 PM, Doug Stone wrote: advantageous to be able to distinguish aVariableName from avariablename? > thanks, > doug > I would not say it is advantageous. Maybe one could argue about a_variable_name vs. AVariableName (bad example for camel case I guess) It is a matter of taste, ... [computer! erase the last sentence!] It is a matter of style and convention, Ruby has chosen the former style and about everybody I know sticks to it. Note that camel case is used for constants and that helps us to distinguish those two;) thus in Ruby it is my_variable and MyConst. in Java it would be MyVariable and MYCONST I believe the Ruby style is more readable but that might be because I read almost infinitely more ruby code than Java code :P. Cheers Robert -- The 1,000,000th fibonacci number contains '42' 2039 times; that is almost 30 occurrences more than expected (208988 digits). N.B. The 42nd fibonacci number does not contain '1000000' that is almost the expected 3.0e-06 times.