From: Shadowfirebird Date: 2010-10-21T06:24:56+09:00 Subject: Re: Long conditional statements Excerpts from Robert Klemme's message of Wed Oct 20 21:44:25 +0100 2010: > That's not the same as "something if a || b || c || d"! Arse. No, of course not. Sorry, long day. I don't think I can beat something() if (a || b || c || d) The important thing, I think, is to factor out the conditional code into something simple to make the whole statement more readable. But of course if I had something() if (a || (b && c || a && c)) I might resort to: complextest = (a || (b && c || a && c) something() if complextest Or I might even make complextest a function.