From: Helmut Leitner Date: 2002-04-01T19:29:49+09:00 Subject: Re: String#begins?(s) Yukihiro Matsumoto wrote: > > Hi, > > In message "String#begins?(s)" > on 02/04/01, Tim Sutherland writes: > > |class String > | def begins?(s) > | self[0...(s.size)] == s > | end > |end > | > |Worthwhile? > > I don't like the name "begins?". It's not obvious. > I don't like names like "beginWith?" or "begin_with?" neither. Would you like "head?" "tail?" ? -- Helmut Leitner leitner@hls.via.at Graz, Austria www.hls-software.com