From: Rich Kilmer Date: 2002-04-01T13:37:53+09:00 Subject: RE: String#begins?(s) What about: String#starts_with?(s) and the corresponding String#ends_with?(s) -rich -----Original Message----- From: Yukihiro Matsumoto [mailto:matz@ruby-lang.org] Sent: Sunday, March 31, 2002 10:32 PM To: ruby-talk ML Subject: Re: String#begins?(s) Hi, In message "String#begins?(s)" on 02/04/01, Tim Sutherland writes: |class String | def begins?(s) | self[0...(s.size)] == s | end |end | |Worthwhile? I don't like the name "begins?". It's not obvious. I don't like names like "beginWith?" or "begin_with?" neither. matz. p.s. If you can find a good name, you've accomplished 90% of the job.